The scheduled maintenance has completed. A very small number of flow runs from during this maintenance window are failing, and we are reaching out to those specific owners.
Posted Oct 22, 2025 - 22:50 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 22, 2025 - 20:00 UTC
Update
Maintenance rescheduled to Wednesday 2025-10-22 (had been Monday)
We will be undergoing scheduled maintenance at this time. We are expecting little-to-no downtime, but there could be short periods (less than 30 minutes) for which flow runs are paused, or the application is not available for live editing.
Posted Oct 20, 2025 - 18:12 UTC
Scheduled
We will be undergoing scheduled maintenance at this time.
Posted Oct 16, 2025 - 18:11 UTC
This scheduled maintenance affected: Flow Builder and Flow Runs.