Flows stay open, even when completed

Incident Report for Parabola

Resolved

This incident has been resolved, flows are running again
Posted Jul 02, 2025 - 22:58 UTC

Monitoring

The flows affected by this incident are being unblocked or restarted
Posted Jul 02, 2025 - 22:41 UTC

Identified

Running flows are not finishing, which blocks further flows from running and blocks the ability to edit flows in the UI.

We have identified the issue and are implementing a fix.
Posted Jul 02, 2025 - 19:56 UTC
This incident affected: Flow Builder and Flow Runs.