Builder Chat Assistant and Custom Transforms broken

Incident Report for Parabola

Resolved

This incident has been resolved.

From 2026-04-22 23:55 UTC to 2026-04-23 02:59 UTC, users were unable to build flows using the assistive chat sidebar
From 2026-04-22 23:55 UTC to 2026-04-23 03:28 UTC, flow runs were failing on custom transforms, AI transforms, and some document parsing
From 2026-04-23 04:00 UTC to 2026-04-23 19:20 UTC, some flow runs failed on custom transform steps, but succeed if retried. Customers with flows that failed during that window should go ahead and re-run their flows.
From 2026-04-23 19:23 UTC to 2026-04-23 19:57 UTC, users were unable to build flows using the assistive chat sidebar and flow runs were failing on custom transforms, AI transforms, and some document parsing

The root-cause was a misconfiguration of our LLM provider. That has been fixed -- we are reviewing to make it more robust.
Posted Apr 23, 2026 - 20:00 UTC

Investigating

We are currently investigating a situation where the chat assistant and custom transforms are not working, as of 2026-04-23 02:20 UTC
Posted Apr 23, 2026 - 02:35 UTC
This incident affected: Flow Builder and Flow Runs.